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General Safety Summary

General Safety Summary
Review the following safety precautions to avoid injury and prevent damage to this product or any products connected to it.

To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures.

While using this product, you may need to access other parts of a larger system. Read the safety sections of the other
component manuals for warnings and cautions related to operating the system.

To Avoid Fire or Personal Injury
Connect and Disconnect Properly. Do not connect or disconnect probes or test leads while they are connected
to a voltage source.

Ground the Product. This product is indirectly grounded through the grounding conductor of the mainframe power cord.
To avoid electric shock, the grounding conductor must be connected to earth ground. Before making connections to the input
or output terminals of the product, ensure that the product is properly grounded.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings and markings on the product. Consult
the product manual for further ratings information before making connections to the product.

Power Disconnect. The power cord disconnects the product from the power source. Do not block the power cord; it
must remain accessible to the user at all times.

Do Not Operate Without Covers. Do not operate this product with covers or panels removed.

Do Not Operate With Suspected Failures. If you suspect that there is damage to this product, have it inspected by
qualified service personnel.

Avoid Exposed Circuitry. Do not touch exposed connections and components when power is present.
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General Safety Summary

Terms in this Manual
These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in damage to this product or other property.

iv RFXpress RFX100 Quick Start User Manual



Preface

Preface
The RFXpress RFX100 is a software product that allows you to create digitally modulated baseband, IF, and RF
signals that can be generated through arbitrary waveform generators (AWG). This software runs as an integral part
of AWG5000/AWG5000B and AWG7000/AWG7000B series arbitrary waveform generators and can also run from an
external PC.

You can use RFXpress to:

Design, debug, and develop wideband wireless communications receivers

Generate UWB-WiMedia compliant and custom signals

Generate general purpose digitally modulated IQ, IF, and RF signals
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Key Features
Define baseband I and Q signals using various modulation schemes

Create single- and multi-carrier signals where each carrier is independently defined

Apply impairments such as quadrature error and imbalance or non-linear impairments

Add interferences during waveform creation

Remotely connect to Tektronix oscilloscopes and to an Agilent Performance Signal Generator (PSG®)

Remotely configure a Tektronix oscilloscope and an Agilent Performance Signal Generator (PSG®)

UWB-WiMedia
Direct RF generation of WiMedia BG1 and BG2 waveforms

Ability to generate IQ and IF waveforms including band hopping for all band groups

User-defined IF frequency including TFC pattern

Comprehensive WiMedia signal generation support for MAC and PHY layers

Ability to create UWB-WiMedia correction files, which can be automatically applied as compensation to accurately
generate signals

Ability to use Gated Noise to define noise profiles for each section of the UWB packet

Create tone nulling with intermediate values (–40 dB to +20 dB) for OFDM carrier mapping

Radar
Create single or multiple pulse groups forming a pulse train

Define each pulse group independently

Create different predefined pulse shapes including user defined shapes for a pulse group

Display a dynamic pulse plot showing the pulse shape, droop, and ripple parameters

Ability to have pulse-to-pulse hopping within a pulse group

Apply impairments like Edge Jitter, Width Jitter, Overshoot, Ripple and Droop on a pulse group

Apply different modulation schemes including user defined modulation

Ability to use the AWG sequence mode to optimize the memory and create large number of pulses

Documentation
RFXpress RFX100 Online Help, English Tektronix part number 076-0081-XX
RFXpress RFX100 User Manual, English, (PDF) Tektronix part number 077-0045-XX
RFXpress RFX100 Quick Start User Manual, English (PDF) Tektronix part number 077-0159-XX
RFXpress RFX100 Installation Manual, English Tektronix part number 077-0160-XX
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Conventions Used in This Manual
When steps require a sequence of selections using the software interface, the ">" delimiter marks each transition between a
menu and an option. For example, File > Save.

The document MultiBand OFDM Physical Layer Specification version 1.2 (Draft) by WiMedia Alliance is referred to as the
“WiMedia standard” or “WiMedia specification”.

The term “DUT” refers to a device under test.

The terms “signal” and “waveform” are used interchangeably in this manual.
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Installation

Installation
For information on how to install this software, refer to the RFXpress Installation Manual, Tektronix part number 077-0160-XX.

Starting the Software
Start the software in either of the following ways:

From Start > Program Files > Tektronix RFXpress, click RFXpress.

Double-click the RFXpress icon on your desktop.

Closing the Software
Click File > Exit to close the software.

Software Upgrades
Periodic software upgrades may become available. The software is operational only if you have a valid option key for the
specific instrument model and serial number.

To check for upgrades:

1. Go to www.tektronix.com/software.

2. Enter the product name (RFXpress).

RFXpress RFX100 Quick Start User Manual 1
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Using the Software

Using the Software
This section covers the following information:

Getting acquainted with the software

Generating a signal

Adding impairments to the signal

Compiling a signal

Graphing a signal

Getting Acquainted with the Software
Using the Software Interface
Use the keyboard or mouse to make selections in the software.

Use menus, toolbars, check boxes, and on-screen buttons to control the software functions. Use Microsoft Windows
techniques to navigate menus and select or clear check boxes.

Generating a Single Carrier Signal
This section shows you a step-by-step procedure for creating a single carrier QPSK baseband signal.

1. Start RFXpress.

2. From the toolbar, click Select > Generic
signal.

3. Set the signal type to IQ.

RFXpress RFX100 Quick Start User Manual 3



Using the Software

4. Click Carriers > Single Carrier.

5. Select the carrier and set the following:

Baseband Offset to 0 Hz

Amplitude to 1 Vrms

6. Ensure that the following parameters are
set:

Modulation is QPSK

Filter is Raised Cosine

Symbol rate is 1 MHz

Alpha/B*T is 0.35

Window is None

Compiling a Signal
Follow these steps to compile and generate a signal using the parameters that you just defined.

1. From the toolbar, click Compile >
Compile Settings.

2. Retain the default values as they are.
Ensure that the Automatic options are
selected.

3. Click Compile.
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Using the Software

4. The compiled waveform is displayed in
the waveform list.

NOTE. If the waveform list is not visible, click Window > Waveform List to view it.

Generating a Multi-Carrier RF Signal
1. From the toolbar, click Select > Generic

signal.

2. Select the signal type as IF/RF.

3. Select Multi Carrier.

4. You can either add carriers directly or
delete the existing carrier and add new
ones. Select the carrier in the table and
click Delete.

RFXpress RFX100 Quick Start User Manual 5



Using the Software

5. Click Add carriers and type 3.

6. Click Range. Set the Base Frequency
to 10 M and the Carrier Spacing to
10 M.

7. Click Add.

8. Select the first carrier from the table.
In the Setup tab, set the Base data to
PRBS and select 15 from the adjacent
field.

9. Set the Modulation for the carrier to
QPSK.

10. Repeat steps 8 and 9 for the remaining
carriers, setting the Base data to
PRBS 21 and PRBS 7, and Modulation
to QPSK.
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Adding Power Ramping, I/Q Impairments, and Interference

1. Select the first carrier from
the table. Select the Power
Ramping tab.

2. Select Turn on.

3. Set the Ramp parameters:

Function to Linear

Time to 100 nsec

4. Set the Position parameters:

Symbol to 0

Level to 0.00

5. Click Add.

6. Repeat steps 4 and 5 two more
times, adding these parameters:

Symbol = 100

Level = –60 dB
and

Symbol = 200

Level = 0 dB

RFXpress RFX100 Quick Start User Manual 7



Using the Software

7. Select the second carrier
from the table. Select the I/Q
Impairments tab.

8. In the Carrier Leakage group,
select Turn on. Set the following
parameters:

I to 5.0

Q to 5.0

9. Select the third carrier from the
table. Select the Interference
Addition tab.

10. In the Offset group, select Turn
on. Set the Frequency to 10 M.

8 RFXpress RFX100 Quick Start User Manual
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Compile Settings and Compile

1. From the toolbar, click Compile >
Compile Settings.

2. Clear Automatic.

3. Set the Waveform length to 500K and
the units to samples.

4. Clear Automatic.

5. Set the Oversampling to 6.00.

6. Click Compile.

7. The compiled waveform is displayed in
the waveform list.

RFXpress RFX100 Quick Start User Manual 9



Using the Software

Previewing Graphs

1. From the toolbar, click Graph.

2. In Graph Setup, select the folder and
click Add to add the following graphs:

Frequency Domain: Spectrum

I Vs Q: Constellation

Statistical: CCDF

3. The graphs are added to the Selected
Graphs.

4. Click OK.

5. Click Graph Preview at the lower left of
the screen to view the graphs.
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Application Examples: Generic Signal

Replay a Captured Waveform to Test Receivers
You can capture a real-world signal in a real-time spectrum analyzer and play it back in multiple locations to test your DUTs.

Import an RTSA File

1. Start RFXpress.

2. Ensure that the selected application is
set to Generic signal and the signal type
is IF/RF.

3. From the menu, click File > Import from
File.

RFXpress RFX100 Quick Start User Manual 11
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4. Select iqt in the Files of type field.

5. Select an iqt file.

6. Select Set as baseband signal.

7. A message appears. Click Continue.
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Application Examples: Generic Signal

8. Click Open.

9. The waveform list displays the I and Q
signals.

10. Note that the Input File Sample Rate
automatically takes the value with which
the iqt file was created.
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11. Select the first carrier and set the
following:

Frequency to 50 M

Amplitude to 0 dBm

12. Click Interference Addition. In the
Sinusoidal Interference group, select
Turn on.

13. Set the following:

C/I to 0 dB.

Offset from Carrier to –10 M.

14. Select the second carrier and repeat
steps 11 through 13.
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15. Click Compile > Compile Settings.
Ensure that Automatic is selected.

16. Click Compile. The software uses the
default compile settings to generate the
waveform.

17. Add the following graphs in Graph Setup:

Frequency Domain: Spectrum

Time Domain: I & Q

18. Click OK.

19. The Spectrum graph is as shown.
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Simulating a MultiPath Environment for a Generic Signal
You can simulate multipath to test your receiver’s response to multipaths.

1. Start RFXpress.

2. From the toolbar, ensure that Select >
Generic signal is selected.

3. Ensure that the signal type is set to
IF/RF.

4. Ensure that Single Carrier is selected.
Keep the default values for the carrier.

5. Click Multi-Path and select Turn on.

6. Set the following parameters:

Delay to 4 symbols

Amplitude to –1 dB

Phase to 30 degrees

7. Click Add.

8. Repeat steps 6 and 7 setting the
following parameters:

Delay to 10 symbols

Amplitude to –5 dB

Phase to 60 degrees
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9. Add the following graph in Graph Setup:

Time Domain: Pulse shape

10. Click OK.

11. From the toolbar, click Compile.

12. The pulse shape is as shown.
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Creating a Hopping Waveform to Test SIGINT Receivers
A SIGINT (Signal Intelligence) receiver assigned to COMINT duty should gather information about all transmissions in the
radio band. The specific tasks of a receiver include the ability to detect and analyze the received transmission, estimate
frequency and modulation type, extract intelligence (information) and locate the source. This example addresses the
challenges in generating a wide range of real-world signals and hopping signals required to test an effective SIGINT receiver.

1. Start RFXpress.

2. From the toolbar, click Select > Generic
signal.

3. Ensure that the signal type is set to
IF/RF.

4. Select Carrier as Multi-Carrier.

5. Select the carrier in the table and click
Delete.

6. In Add carriers, enter 6 and click Add.

7. Select the carriers one after another,
starting with the first carrier.

8. Enter the values for each carrier as in
Table 1. (See page 20.)
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Application Examples: Generic Signal

9. Select the sixth carrier and click Set
Anchor.

10. Click the Hopping tab and select Turn
on.

11. Update the values as shown in Table 2
for each carrier: (See page 21.)

12. From the toolbar, click Compile >
Compile Settings.

13. Disable Automatic and set Waveform
length to 384 symbols.

14. Click Compile.
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15. From the waveform list, select an IF/RF
waveform. Right-click and select Show
Graph > Spectrogram.

16. The spectrogram is as shown.

Table 1: Carrier parameters

Signal
number

Carrier
frequency
(MHz)

Amplitude
(dBm) Modulation

Symbol rate
(MHz) Filter Window

1 31 –6 QPSK 0.5 RC Blackman
2 79 0 8-PSK 2 Root Raised

Cosine
Hamming

3 237 4 FM 30 KHz - None
4 432 10 64-QAM 1 Gaussian

(Dirac Delta)
Hamming
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Table 1: Carrier parameters (cont.)

Signal
number

Carrier
frequency
(MHz)

Amplitude
(dBm) Modulation

Symbol rate
(MHz) Filter Window

5 131 1 Pi 1/4 QPSK 5 RC Blackman
6 673 0.5 BPSK 2 RC None

Table 2: Hopping parameters

Signal number Start symbol End symbol
Relative amplitude
(dB)

Frequency offset
(MHz)

1 1 127 0 –25
2 128 255 0 0
3 256 384 0 –50

Calibrating a Generic Signal
When creating signals for testing wideband recievers, it is important that the test equipment generate signals with flat
frequency and linear phase response. As the signal bandwidth is increased, because of the DAC roll-off and bandwidth
limitation of the arbitrary waveform generator, the signal created does not have flat frequency and linear phase response.
Calibration (predistortion) is applied to signals to correct amplitude and phase distortions.

1. Set up the instruments as shown. The
instruments must be connected over a
LAN.
You will need:

A Tektronix AWG7102 with Option 06
running RFXpress software.

A Tektronix DPO oscilloscope to
capture the signal. Ensure that the
oscilloscope is calibrated.

Connecting cable.

NOTE. Ensure that the output of the AWG
Interleave channel is connected to Channel 1
of the oscilloscope and Marker 1 of the
AWG is connected to Aux In of the DPO
oscilloscope.

2. Start RFXpress.
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3. From the toolbar, click Select > Generic
signal and signal type as IF/RF.

4. For the carrier, set the following:

Base data to PRBS and User
Defined

Frequency to 5 GHz

Symbol rate to 2 GHz

5. From the toolbar, click Compile >
Compile Settings.

6. Disable Automatic and set the
Waveform length to 200 K symbols.

7. Ensure that When compiling, apply
correction files to these channels is
disabled.

8. Click Compile.

22 RFXpress RFX100 Quick Start User Manual



Application Examples: Generic Signal

9. Capture the waveform in the
oscilloscope. The signal spectrum
is observed using Tektronix Ultra
Wideband Spectral Analysis software.

10. Note that the EVM value before
calibration is 14.65%.

11. From the toolbar, click Calibration.

NOTE. You will be prompted with a message
to compile your setup, if you have not already
done so. Click Continue to proceed with
calibration.
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12. The Calibration window displays a table
of instruments connected on the network.
Select the DPO oscilloscope and click
Connect. Note that the status changes
to Connected.

NOTE. You can click Test Connection to test
the status of the instrument.

13. Set the following:

Start Frequency to 3.5 GHz

End Frequency to 6.5 GHz

Select the correction file name to
generate the correction file

Select Ch 1

14. Click Calibrate. Follow the prompt and
continue. After calibration, click OK.

15. From the toolbar, click Compile >
Compile Settings.

16. Ensure that the correction file created
during calibration is applied to Ch1.

17. Click Compile.
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18. Capture the calibrated waveform in the
oscilloscope. The signal spectrum is
observed using Tektronix Ultra Wideband
Spectral Analysis software.

19. Note that the EVM value after calibration
is 6.52%.
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Creating a UWB Waveform to Test Your Receivers
You can create an ideal waveform and use it to test whether your receivers are operating within the WiMedia specifications.

1. Start RFXpress.

2. From the toolbar, click Select >
UWB-WiMedia.

3. By default, Conformance is selected.

4. From the Select Setup, select WiMedia
Spec Example Packet.

5. The WiMedia Spec Example Packet
settings (according to Annex A of the
WiMedia specification document) are
displayed in the fields in each tab.

6. Confirm the Hopping Pattern for TF
Code 1.

7. Click Compile.
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8. Add the following graphs in Graph Setup:

Frequency Domain: Spectrum

I Vs Q: Constellation

Time Domain: I & Q

9. Click OK.

10. The graphs are as shown.
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Characterize Receiver Design for Receiver Verification and Stress Test
You can generate a signal and use it to test your receiver at conditions just outside the boundary values specified by the
WiMedia standard.

1. Start RFXpress.

2. From the toolbar, click Select >
UWB-WiMedia.

3. Set the signal type to IF/RF.

4. Select Custom.

5. From the Select Setup, select WiMedia
Spec Example Packet.

6. The default values for the selected setup
and packet are shown graphically.

7. For the selected packet group, set TF
Code to User Defined.

8. To define a hopping pattern: In each
column, click the frequency that you
want to use. Set the hopping pattern to:
323323.

9. Assign a TFC number for the pattern that
you defined and click OK.
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Adding Interference

1. Click Interference Addition.

2. In the Gated Noise group, select Turn
on.

3. Click Packets.

4. Click PLCP Header and set it to –10.0.

5. From the toolbar, click Compile.

6. In the Waveform List, select the IF/RF
waveform and right-click. Select Show
Graph > Time domain.

7. Observe the noise in the header. The
noise of 10 dB is greater than the signal.
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Using Calibration to Increase the Flatness of a UWB Signal Path to the DUT
The calibration feature allows you to generate correction files that you can use during compilation to predistort the signal,
thereby increasing the flatness of the signal.

1. Set up the instruments as shown. The
instruments must be connected over a
LAN.
You will need:

A Tektronix AWG7102 with Option 06
running RFXpress software.

A Tektronix DPO70804 oscilloscope
to capture the signal. Ensure that the
oscilloscope is calibrated.

Connecting cable.

NOTE. Ensure that the output of the AWG
Interleave channel is connected to Channel
1 of the oscilloscope.

2. Start RFXpress.

3. From the toolbar, click Select >
UWB-WiMedia.

4. From the toolbar, click Calibration.

5. The Calibration window displays a table
of instruments connected on the network.
Select the DPO70804 oscilloscope and
click Connect. Note that the status
changes to Connected.

NOTE. You can click Test Connection to test
the status of the instrument.

6. Set the signal type to RF.

7. Set the Sampling Rate to
19.996576 GS/s.

8. Select InterLeave.

9. Set the Average to 10.

10. Set the Band group to 2.

11. Select Bands: 1, 2, and 3.
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12. Set When compiling, apply correction
files to to Ch1.

13. Set the Amplitude for Ch 1 to 0.5 Vpp.

14. Set the path for Select the correction
file.

15. Click Calibrate to create the correction
file (.rfc). The calibration status is
continually updated.

16. Confirm that the correction file that was
just generated is selected.

17. Set Band Group to BandGroup 2.
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18. From the toolbar, click Compile >
Compile Settings.

19. Ensure that the correction file created
during calibration is applied to Ch1.

NOTE. Oversampling is calculated
automatically to achieve a sampling rate of
19.996576 GS/s.

20. Click Compile.

Creating a Band Group 6 Signal Using an External IQ Modulator
You can create a Band Group 6 WiMedia signal using an AWG7102 and an external IQ modulator like the Agilent PSG®.
The AWG7102 is used to generate a hopping baseband signal which will be fed to PSG to modulate it to the desired Band
Group 6 center frequency of 8184 MHz. The signal would have to be calibrated to adjust the channel mismatches. Channel
mismatches result in images and carrier leakage. Carrier leakage is caused by the offset mismatch between the channels
and images by the amplitude and skew mismtaches. To eliminate images you must calibrate the signal for all the tones. In
this application example, an extreme tone from the center frequency is taken and calibrated.
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1. You will need the following equipment,
with each piece calibrated:

A Tektronix AWG7102 with Option 06
running RFXpress software

A Tektronix DSA72004 oscilloscope
to capture the signal. The Tektronix
Ultra Wideband Spectral Analysis
software must be loaded and running
on the oscilloscope

An Agilent Performance Signal
Generator PSG® E8267D with
Option 015

A Tektronix RSA6114A Real Time
Spectrum Analyzer

Matched pair connecting cables to
connect between the PSG E8267D
and the AWG7102

2. Connect the equipment as shown.
Either the DSA72004 oscilloscope or
the RSA6114A Real Time Spectrum
Analyzer can be used as the DUT.
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3. On the PSG E8267D, do the following:

Set I/Q to On.

Set I/Q Path to Wide.

Select IQ Calibration. Set
Calibration Type to Full and execute
calibration.

Set Frequency to 8184 MHz (for
BandGroup 6) and Amplitude to
0 dBm.

4. Connect the RF output of the PSG
E8267D to the oscilloscope (DUT).

5. On the AWG7102, start RFXpress.

6. Set the following:

Application to UWB-WiMedia

Signal type to IQ

Mode to Conformance

Band Group to 6
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7. Click Compile > Compile Setting.
Ensure that Compiles and Sends to is
set to Ch1 and Ch2. Click Compile to
generate the signal.

8. On the PSG E8267D, do the following:

Set Modulation to On.

Set RF to On.

9. The signal is sent to oscilloscope (DUT);
capture and demodulate it using the
Tektronix Ultra Wideband Spectral
Analysis software. If the software is
unable to decode the signal, go to step
10 to proceed with calibrating the signal.

10. Disconnect the oscilloscope and connect
the RF output of the PSG E8267D to the
RSA6114A (DUT).
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11. On the AWG7102, using a standard
waveform, generate a sine wave with a
Frequency of 700 MHz, Cycle of 500,
and the sampling rate set to No Change.

12. Drag and drop the sine wave (signal) into
Ch 1 and Ch 2.

13. Click Ch 1 and set Waveform Rotation
to 0.18 degrees. Leave Ch2 unchanged.

NOTE. On the AWG7102, the waveform
rotation value will be shown as 0.2°.

14. Click On/Off. Click Run.
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15. On the RSA6114A, do the following:

Set Frequency to 8184 MHz.

Set Span to 50 MHz.
Observe whether there is a carrier
leakage at 8184 MHz. If you find a
frequency component at 8184 MHz,
proceed witht he calibration or else go
to step 18.

16. On the PSG E8267D, do the following:

Set I/Q Adjustments to On.

Adjust the I Offset and Q Offset until
the carrier leakage reduces to the
noise floor.

You may have to adjust the values
iteratively.

17. Observe the change in the signal on the
RSA6114A.
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18. On the RSA6114A, do the following:

Set Center Frequency to
8184–700 MHz (that is 7484 MHz).

Set Span to 50 MHz.
Observe whether there is an image at a
frequency of 7484 MHz. If there is an
image, proceed to calibrate the signal. If
there is no image, proceed to step 21.

19. On the AWG7102, adjust the Amplitudes
and Channel Skews to reduce the image
to the noise floor.
You may have to adjust the values
iteratively. Observe the change in the
signal on the RSA6114A.

20. Make a note of the amplitudes and skew
values of Ch 1 and Ch 2.

21. Go to RFXpress and click Compile.
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22. Connect the RF output of the PSG
E8267D to the oscilloscope (DUT).

23. On the AWG7102, set the values noted
in step 20:

Amplitudes of Ch 1 and Ch 2.

Skew values of Ch 1 and Ch 2.

Waveform rotation to 0.

24. Observe that the signal is decoded on
the oscilloscope.

Introducing Real-World Impairments in a UWB Signal
You can introduce real-world impairments in a UWB signal to test your receiver in a simulated real-world environment.

1. Start RFXpress.

2. From the toolbar, click Select >
UWB-WiMedia.

3. Ensure that the signal type is set to
IF/RF.

4. Ensure that the Mode is Conformance
and the Selected setup is WiMedia
Spec Example Packet. Keep the default
values for the selected setup.
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5. Click Interference Addition.

6. In the Real World Signal Interference
group box, click Turn on.

7. Click Add WiFi signal (MIMO).

8. Set the following parameters:

Frequency to 2.4 G Hz (default).

Amplitude to 30 dB.

9. Add the following graph in Graph Setup:

Frequency Domain: Spectrum

10. Click OK.
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11. From the toolbar, click Compile.

12. The spectrum is as shown.
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Generating an LFM Waveform with Coherent Carrier for Pulse Compression
Radar

You can use the Radar plug-in to generate an LFM waveform with coherent carrier for pulse compression radar.

1. Start RFXpress.

2. From the toolbar, click Select > Radar.

3. Click the Carrier tab.

4. Keep the following defaults:

Carrier Magnitude (Peak) to 0 dBm.

Carrier Frequency to 100 MHz.

Coherent Carrier is selected.
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5. Select the Pulse tab and select the
Pulse Envelope tab.

6. Set the following:

Pulse Shape to Rectangular
(default).

Start Time to 0 ps (default).

Pulse Width to 10 µs at 100%.

Off Time to 198 µs.

NOTE. The PRF and PRI values are
calculated and automatically updated based
on the parameters that you just set. In this
case, the PRF is 4.807 KHz and the PRI (in
the table) is 0.2080 ms.

Amplitude Relative to Carrier to
0 dB (default).

Offset from Carrier Frequency to
0 Hz (default).

Repeat to 1 (default).

7. Click the Modulation tab.

8. Set the following:

Select Modulation to Linear
Frequency Modulation.

Sweep Range to 10 MHz.

Frequency Sweep to Low to High.

9. From the toolbar, click Compile
Settings.
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10. Ensure the following:

Signal Format is IF/RF.

Automatic is selected.

11. Click Compile.

12. The compiled pulse is displayed in the
Waveform List. In the Waveform List,
select the I signal and right-click. Select
Show Graph > Time domain to display
the graph of the pulse.

13. Click Zoom In and select an area to
zoom.
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Generating a Hopping Radar Waveform: Creating a Pulse-to-Pulse Frequency
Hopping Signal

A pulse-to-pulse hopping radar signals are also known as frequency agile waveforms. Pulse-to-pulse hopping is used in
electronic counter measures by rapidly switching the frequency of the transmitted energy and receiving only that frequency
during the receiving time window.

1. Start RFXpress.

2. From the toolbar, click Select > Radar.

3. In the Carrier tab, ensure that Coherent
Carrier is selected (default).

4. Set the following:

Carrier Magnitude (Peak) to
2.5 dBm.

Carrier Frequency to 200 MHz.

5. Select the Pulse tab and select the
Pulse Envelope tab.

6. Set the following:

Pulse Shape to Raised Cosine.

Start Time to 0 ps (default).

Rise Time to 0.1 µs at 20–80%.

Pulse Width to 15 µs at 50%.

Fall Time to 0.1 µs at 20–80%.

Off Time to 30 µs.

NOTE. The PRF and PRI values are
calculated and automatically updated based
on the parameters that you just set. In this
case, the PRF is 22.102 KHz and the PRI (in
the table) is 0.0452 ms.

Amplitude Relative to Carrier to
0 dB (default).

Offset from Carrier Frequency to
0 Hz (default).

Repeat to 6.

RFXpress RFX100 Quick Start User Manual 45



Application Examples: Radar

7. Click the Modulation tab and set Select
Modulation to No Modulation.

8. Click the Hopping tab and select Turn
on.

9. In the table, click Add to add rows.

NOTE. You cannot add more rows than the
repeat value (6 in this case)
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10. Set the following:

Frequency Offset for the first hop to
50 MHz.

Frequency Offset for the second hop
to 40 MHz.

Frequency Offset for the third hop to
–50 MHz.

Frequency Offset for the fourth hop
to 0 MHz.

Frequency Offset for the fifth hop to
30 MHz.

Frequency Offset for the sixth hop to
–30 MHz.

11. From the toolbar, click Compile
Settings.

12. Ensure the following:

Signal Format is IF/RF.

Automatic is selected.

13. Click Compile.
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14. The compiled pulse is displayed in the
Waveform List. In the Waveform List,
select the IF/RF signal and right-click.
Select Show Graph > Spectrogram to
display the graph of the pulse.

15. The spectrogram is as shown.

NOTE. For better resolution, increase the
frame size and click Refresh.

16. The spectrogram as seen in a Tektronix
RSA6100A is as shown.
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Creating Costa’s Modulation
You can use RFXpress to test receivers with Costa’s modulation which are used for better range and Doppler resolution.

1. Start RFXpress.

2. From the toolbar, click Select > Radar.

3. Click the Carrier tab.

4. Keep the defaults for Coherent Carrier
(enabled) and Carrier Magnitude
(Peak).

5. Set the desired Carrier Frequency, for
example to 1 GHz.

6. Select the Pulse tab and select the
Pulse Envelope tab.

7. Set the following:

Pulse Shape to Rectangular.

Pulse Width to 112 µs.

Off Time to 100 µs.
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8. Click the Modulation tab and set Select
Modulation to User Defined Step FM.
You will create a Costa’s code of seven
steps with Δf = 42.4 MHz. The code that
will be used is 3605412.

9. In Add Steps enter 7.

10. Click Add.

11. In the table, enter the following:

Duration to 16000 ns.

Frequency to 127.2 MHz.

12. Repeat step 11 for all the steps in
the code. Keep the duration constant
(16000 ns) and calculate the frequency
using the formula Δf * code (for example
42.5 * 3, 42.5 * 6, 42.5 * 0, and the rest).

13. From the toolbar, click Compile.
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14. In the waveform list, select the IF/RF.
Right-click and select Show Graph >
Spectrogram.

15. The spectrogram is as shown.
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Creating a Radar Waveform using Staggered PRI for Better Range Ambiguity
One of the applications of Staggered PRI is in Moving Target Indication (MTI) Radars which have to resolve range and
Doppler ambiguities. In this example shows how to create pulse-to-pulse staggering.

1. Start RFXpress.

2. From the toolbar, click Select > Radar.
Select the signal type as IF/RF.

3. Click the Carrier tab.

4. Keep the defaults for Coherent Carrier
(enabled) and Carrier Magnitude
(Peak).

5. Set the Carrier Frequency to 1 GHz.

6. Select the Pulse tab and select the
Pulse Envelope tab.

7. Set the following:

Pulse Shape to Rectangular.

Pulse Width to 11.2 µs.

Off Time to 33.6 µs.

Repeat to 5.
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8. Click the Staggered PRI tab and select
Turn on.

9. Set Staggered PRI type to User Defined.
You will change the PRI for each pulse by
adding a deviation. The PRI is calculated
as follows: Current PRI + deviation. The
deviation is specified in the table.

10. Click Add to add a row to the table.

11. Enter the deviation –0.0064 (in ms) for
the first pulse.

12. Repeat steps 10 and 11 to enter the
deviation for the remaining pulses as:
0, 0.0053, –0.0085, and 0.0013.

13. From the toolbar, click Compile.
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14. In the waveform list, select the IF/RF.
Right-click and select Show Graph >
Time domain.

15. The time domain graph is as shown.

Simulating Multiple Targets for Radar Receiver Testing (Different Pulse
Groups)

You can use RFXpress to simulate three targets. Assuming that the transmitter sends a pulse of duration 5 µs with a PRI of
500 µs, we will simulate three targets – the first at 40 µs from the referece, the second at 120 µs, and the third at 300 µs.

1. Start RFXpress.

2. From the toolbar, click Select > Radar.
Select the signal type as IF/RF.

3. Click the Carrier tab.

4. Keep the defaults for Coherent Carrier
(enabled) and Carrier Magnitude
(Peak).

5. Set the Carrier Frequency to 1 GHz.
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6. Select the Pulse tab and select the
Pulse Envelope tab.

7. Set the following:

Pulse Shape to Rectangular.

Start Time to 40 µs.

Pulse Width to 5 µs at 100%.

Off Time to 50 µs.

Amplitude Relative to Carrier to
0 dB (default).

8. Click the Modulation tab and set
Select Modulation to Linear Frequency
Modulation.

9. Set the following:

Sweep Range to 10 MHz.

Frequency Sweep to Low to High.
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10. Click Add to add a pulse. Select the
newly added pulse.

11. Select the Pulse Envelope tab.

12. Select the pulse and set the following:

Pulse Shape to Rectangular.

Start Time to 25 µs.

Pulse Width to 5 µs @ 100% .

Off Time to 175 µs.

Amplitude Relative to Carrier to
–2 dB.

13. Click the Modulation tab and set
Select Modulation to Linear Frequency
Modulation.

14. Set the following:

Sweep Range to 10 MHz.

Frequency Sweep to Low to High.

56 RFXpress RFX100 Quick Start User Manual



Application Examples: Radar

15. Click Add to add a pulse.

16. Select the Pulse Envelope tab.

17. Select the pulse and set the following:

Pulse Shape to Rectangular.

Start Time to 0 µs.

Pulse Width to 5 µs @ 100% .

Off Time to 195 µs.

Amplitude Relative to Carrier to
–3 dB.

18. Click the Modulation tab and set
Select Modulation to Linear Frequency
Modulation.

19. Set the following:

Sweep Range to 10 MHz.

Frequency Sweep to Low to High.

20. From the toolbar, click Compile.
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21. In the waveform list, select an IF/RF
waveform from the list. Right-click and
select Show Graph > Time domain.

22. The time domain graphs are as shown.
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Generating and Measuring a Wideband LFM with Calibration using a Tektronix
Oscilloscope

1. Set up the instruments as shown. The
instruments must be connected over a
LAN.
You will need:

A Tektronix AWG7102 with Option 06
running RFXpress software.

A Tektronix DPO oscilloscope to
capture the signal. Ensure that the
oscilloscope is calibrated.

Connecting cable.

NOTE. Ensure that the output of the AWG
Interleave channel is connected to Channel 1
of the oscilloscope and Marker 1 of the
AWG is connected to Aux In of the DPO
oscilloscope.

2. Start RFXpress on the AWG7102.

3. From the toolbar, click Select > Radar.
Select the signal type as IF/RF.

4. Click the Carrier tab.

5. Keep the defaults for Coherent Carrier
(enabled) and Carrier Magnitude
(Peak).

6. Set the Carrier Frequency to 5 GHz.
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7. Select the Pulse tab and select the
Pulse Envelope tab.

8. Set the following:

Pulse Shape to Rectangular.

Pulse Width to 100 µs.

Off Time to 10 µs.

9. Click the Modulation tab and set
Select Modulation to Linear Frequency
Modulation.

10. Set the following:

Sweep Range to 2 GHz.

Frequency Sweep to Low to High.

11. From the toolbar, click Compile >
Compile Settings.
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12. Ensure that When compiling, apply
correction files to these channels is
disabled.

13. Click Compile.

14. Capture the waveform on the
oscilloscope and observe the signal
spectrum using Tektronix Ultra Wideband
Spectral Analysis software. Note that the
spectrum is not flat.

15. From the toolbar, click Calibration.

NOTE. You will be prompted with a message
to compile your setup, if you have not already
done so. Click Continue to proceed with
calibration.
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16. The Calibration window displays a table
of instruments connected on the network.
Select the DPO oscilloscope and click
Connect. The status changes to Ready.

NOTE. You can click Test Connection to test
the status of the instrument.

17. Set the following:

Start Frequency to 3.5 GHz

End Frequency to 6.5 GHz

Enter the path for the correction files

For While compiling, apply
correction files to, select Ch1

18. Click Calibrate. After the calibration is
complete, click OK.

19. From the toolbar, select Compile >
Compile Settings.

62 RFXpress RFX100 Quick Start User Manual



Application Examples: Radar

20. Ensure that When compiling, apply
correction files to these channels is
enabled and Ch 1 is selected.

21. Click Compile.

22. Capture the waveform on the
oscilloscope and observe the signal
spectrum using Tektronix Ultra Wideband
Spectral Analysis software. Note that the
spectrum shows a flat response.
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Interference Addition tab, 8, 14, 29,
40

Interleave, 30
IQ calibration, 34
IQ type, 34

RFXpress RFX100 Quick Start User Manual 65



Index

K
Key features

baseband, vi
radar, vi
UWB-WiMedia, vi

M
Manuals, vi

RFXpress RFX100
Installation, vi, 1

RFXpress RFX100 User, vi
Modulation, 4, 6, 43, 46, 50, 55, 56,

57, 60
duration, 50
frequency, 50

Mulitpath tab, 16
Multi-Carrier

add carrier, 6
Multi-Carrier signals, vi

RF, 5
Multipath

simulating, 16

O
Off time, 43, 45, 49, 52, 55, 56, 57,

60
Offset from carrier, 14
Offset from carrier frequency, 43, 45
On/Off, 36
Online help, vi
Oscilloscope, 21, 59

DPO70804, 30
DSA72004, 33, 34, 35, 39

Oversampling, 9

P
Packets, 29
Performance signal generator

E8267D, 33, 34, 35, 37, 39
Phase, 16

PLCP Header, 29
Power ramping, 7, 29

adding, 7
Power ramping tab, 7
Preface, v
Previewing Graphs, 10
PRF, 43, 45
PRI, 43, 45
Pulse

envelope, 43, 45, 49, 52, 55,
56, 57, 60

shape, 43, 45, 49, 52, 55, 56,
57, 60

width, 43, 45, 49, 52, 55, 56,
57, 60

Pulse hopping, vi

Q
Q offset, 37

R
Range, 6
Real time spectrum analyzer

RSA6114A, 33, 35, 37, 38
Repeat, 43, 45, 52
Rise time, 45
Run, 36

S
Safety Summary, iii
Sampling rate, 30, 36
Setup tab, 6
Signal

compiling, 4
generating, 3
previewing, 10

Signal type
IF/RF, 24
IQ, 3
RF, 5, 30, 34

Single carrier signals, vi
generating, 3

Software upgrades, 1
Span, 37, 38
Spectrogram, 20
Staggered PRI, 53

type, 53
Start frequency, 24
Start time, 43, 45, 55, 56, 57
Starting the software, 1
Sweep range, 43, 55, 56, 57, 60
Symbol rate, 4

T
Tek UWB Spectral Analysis

software, 33, 35
TF Code

user defined, 28

U
UWB, v
UWB-WiMedia, v, 26, 28, 30, 34

conformance mode, 26
custom mode, 28

W
Waveform length

automatic, 19
Waveform list, 5, 29
Waveform rotation, 36, 39
WiFi signal, 40
WiMedia spec example packet, 26,

28
WiMedia specification, vii
Window, 4

66 RFXpress RFX100 Quick Start User Manual


	toc
	General Safety Summary
	Preface
	Key Features
	Documentation
	Conventions Used in This Manual

	Installation
	Starting the Software
	Closing the Software
	Software Upgrades

	Using the Software
	Getting Acquainted with the Software
	Generating a Single Carrier Signal
	Generating a Multi-Carrier RF Signal

	Application Examples: Generic Signal
	Replay a Captured Waveform to Test Receivers
	Simulating a MultiPath Environment for a Generic Signal
	Creating a Hopping Waveform to Test SIGINT Receivers
	Calibrating a Generic Signal

	Application Examples: UWB-WiMedia
	Creating a UWB Waveform to Test Your Receivers
	Characterize Receiver Design for Receiver Verification and Stres
	Using Calibration to Increase the Flatness of a UWB Signal Path 
	Creating a Band Group 6 Signal Using an External IQ Modulator
	Introducing Real-World Impairments in a UWB Signal

	Application Examples: Radar
	Generating an LFM Waveform with Coherent Carrier for Pulse Compr
	Generating a Hopping Radar Waveform: Creating a Pulse-to-Pulse F
	Creating Costa’s Modulation
	Creating a Radar Waveform using Staggered PRI for Better Range A
	Simulating Multiple Targets for Radar Receiver Testing (Differen
	Generating and Measuring a Wideband LFM with Calibration using a




<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.3
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.1000
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 150
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Average
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.40
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 150
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.40
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName (http://www.color.org)
  /PDFXTrapped /Unknown

  /SyntheticBoldness 1.000000
  /Description <<
    /FRA <>
    /JPN <FEFF3053306e8a2d5b9a306f30019ad889e350cf5ea6753b50cf3092542b308000200050004400460020658766f830924f5c62103059308b3068304d306b4f7f75283057307e30593002537052376642306e753b8cea3092670059279650306b4fdd306430533068304c3067304d307e305930023053306e8a2d5b9a30674f5c62103057305f00200050004400460020658766f8306f0020004100630072006f0062006100740020304a30883073002000520065006100640065007200200035002e003000204ee5964d30678868793a3067304d307e30593002>
    /DEU <>
    /PTB <>
    /DAN <>
    /NLD <>
    /ESP <>
    /SUO <>
    /ITA <>
    /NOR <>
    /SVE <>
    /ENU <>
  >>
>> setdistillerparams
<<
  /HWResolution [1200 1200]
  /PageSize [612.000 792.000]
>> setpagedevice


